Joshua Stream Pre
Page 2 of 6 First 1234 ... Last
  1. #11
    Unfortunately, it isn't working for a first level caster either
    Glad you caught that 9th level bug, it would have come up next! That charges optimization should mean this is purely point and click when it's done. love it.

    What is new after this update is a message "nil" that appears in the chat when I change the carried/equipped status. It shows up when the wand is named "wand of summon swarm" but not "Wand (summon swarm)". Neither title works.

  2. #12
    Do you have anything else in the Wand of Summon Swarm name? or the Wand (Summon Swarm)?
    It's working for me so I'm trying to isolate what might be different.
    Part of the problem with testing to trying to figure out all the ways people might do something that wasn't what you intended.

    The nil was me missing removing a Debug.chat() command. Found 2 of them and they have both been removed.
    Now I just need to figure out what's different between your wand and mine.
    I have Wand of Summon Swarm [37] (3). I also did a Wand (Magic Missile) and it properly set it to level 1.
    Could you put a screen shot of the item window for your wands not working? That way I can see what to work with.
    Are there any that are working?

    I'll post a new update once I figure out how to fix what's not working.

    Thanks.
    Last edited by rmilmine; May 21st, 2020 at 21:44.

  3. #13
    Here are the wands I'm using to test it:
    wands.png
    Here is me creating a new campaign, starting a character, going to actions, adding the wands to inventory, and equipping them with no effect (with v1.0.2):
    --video deleted--
    Last edited by bmos; August 14th, 2020 at 17:53.

  4. #14
    I just created those two wands created a character as a bard and added the wands.
    There was no error message and they added proper action items for them both.

    wands.JPG
    wands action tab.JPG

    I am not sure what is causing the problem.

    What version of FGC are you using?
    Could you please list the extensions and version numbers. maybe there is a version conflict.
    I'll try doing more testing, but I'm at a loss as to why it's not working for you.

  5. #15
    FGC: 3.3.10 Ultimate
    Advanced Character Inventory Manager for 3.5E and Pathfinder: 1.0.2
    Advanced Effects for 3.5E and Pathfinder: 1.1.1
    Customized Item Generator for 3.5E and Pathfinder: 1.0.1
    PFRPG - Enhanced Items: v4.21

    I'll try reinstalling Fantasy Grounds Classic sometime, something could be borked.

    EDIT: I reinstalled FG today and installed only the 4 mods listed. Same behavior.
    I zipped up the test campaign folder with my test character and wands in case that helps, although I don't see how it could be anything in the campaign (since I made a new one and it did the same thing):
    https://drive.google.com/file/d/18FC...ew?usp=sharing

    I also tried creating those wands from scratch like you did rather than using the ones from the AP and no change.
    Last edited by bmos; May 22nd, 2020 at 17:01.

  6. #16
    Hello there. If it can helps I can add my experience to the issue presented by bmos.

    I was having the same issue and the extension was not working with this setup:

    Newly created campaign
    Extensions: "Advanced Character Inventory Manager for 3.5E and Pathfinder" + "PFRPG - Enhanced Items"
    Modules: Paizo Official Core Rules + Ultimate Magic + APG + PFRPG Magic Items (Essential) or Ultimate Equipment by Faelwen (https://www.fantasygrounds.com/forum...mate-Equipment).

    With this setup it was not working just like bmos was showing in his video.

    Tried to open the module PFRPG Archive Spells by Ken L (not available anymore - I had it before and still using it most of the time as the only spell module active) and still not working.

    Finally tried to open PFRPG Spells (Essentials) or Farnaby's Spellbook (https://www.fantasygrounds.com/forum...FRPG-Spellbook) and now it's working properly with both of them.

    So I guess the problem is some kind of a conflict with the module used for spells

  7. #17
    Quote Originally Posted by AndreBLJ View Post
    Hello there. If it can helps I can add my experience to the issue presented by bmos.

    I was having the same issue and the extension was not working with this setup:

    Newly created campaign
    Extensions: "Advanced Character Inventory Manager for 3.5E and Pathfinder" + "PFRPG - Enhanced Items"
    Modules: Paizo Official Core Rules + Ultimate Magic + APG + PFRPG Magic Items (Essential) or Ultimate Equipment by Faelwen (https://www.fantasygrounds.com/forum...mate-Equipment).

    With this setup it was not working just like bmos was showing in his video.

    Tried to open the module PFRPG Archive Spells by Ken L (not available anymore - I had it before and still using it most of the time as the only spell module active) and still not working.

    Finally tried to open PFRPG Spells (Essentials) or Farnaby's Spellbook (https://www.fantasygrounds.com/forum...FRPG-Spellbook) and now it's working properly with both of them.

    So I guess the problem is some kind of a conflict with the module used for spells
    I thought I had mentioned this, and apparently I didn't. You need to have a module loaded that includes the spell that is in the wand, potion or scroll. Names need to be the same spelling.

  8. #18
    Quote Originally Posted by rmilmine View Post
    I thought I had mentioned this, and apparently I didn't. You need to have a module loaded that includes the spell that is in the wand, potion or scroll. Names need to be the same spelling.
    Yeah you did!

    My actual campaign is using the old nice Archive Spells which is a massive module with I really like and he's probably using the same or something similar. That's why it wasn't working for us!

    Apparently the spelling is different in that module

  9. #19
    Easier to change the wand name to get it working. I would think that Dispel Magic could only be done one way. How are they done in this module?

  10. #20
    Quote Originally Posted by rmilmine View Post
    Easier to change the wand name to get it working. I would think that Dispel Magic could only be done one way. How are they done in this module?
    First: I have literally 0 knowledge about extensions and their coding so I can just test in game different setups, sorry. No idea if I can help with my reports

    I tried multiple combinations with spell modules and it's only working with PFRPG Spells (Essentials) and Farnaby's Spellbook.

    To sum up (at least for me):

    Pathfinder Core Rules (Paizo Inc.): not working
    PFRPG Archive Spells (Ken L.): not working
    Farnaby's Spellbook: working
    PFRPG Spells (Essentials) working

    I can provide a screen with Dispel Magic from each of them:
    difference.jpg

    Left to right: Pathfinder Core Rules - PFRPG Archive Spells - Farnaby's Spellbook - PFRPG Spells (Essentials)

    No idea if this is what you were asking for, honestly. Trying my best :P

    Maybe someone else could try with these same modules and check if they work for them and it's me!
    Last edited by AndreBLJ; May 27th, 2020 at 21:49.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Fantasy Grounds Fridays Pre

Log in

Log in